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CHAPTER 1

Introduction to AutoCAD 2024

What is AutoCAD?

AutoCAD is a professional computer-aided design (CAD) and drafting software developed by Autodesk.

Used by architects, engineers, surveyors, and designers worldwide, it allows you to create precise 2D

drawings and 3D models digitally — replacing traditional pen-and-paper drafting with speed and accuracy.

AutoCAD 2024 includes an updated Smart Blocks panel, improved PDF import performance, enhanced

collaboration tools, and a modernized ribbon. This guide focuses entirely on 2D drafting fundamentals

— the foundation every AutoCAD user must master first.

★

TIP

AutoCAD 2024 is available as a free 30-day trial. Visit autodesk.com/products/autocad

to download it before starting this guide.

■
■ What is AutoCAD? — Official Autodesk Introduction

Autodesk's own overview of AutoCAD 2024: interface tour, real-world uses, and what's
new.

https://www.youtube.com/results?search_query=what+is+autocad+2024+overview+beginners

Installing & Activating AutoCAD 2024

1 Go to the Autodesk Website

Open your browser and navigate to autodesk.com. Click Products > AutoCAD.

2 Start a Free Trial or Sign In

Click Free Trial if this is your first time, or sign in with your Autodesk account to access a

purchased license.

3 Download the Installer

Select AutoCAD 2024 from the product list. Choose your operating system (Windows or

macOS) and click Download.

4 Run the Installer

Double-click the downloaded file. Follow the on-screen prompts: Accept the license,

choose your install location, and click Install.
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5 Launch & Sign In

Once installed, open AutoCAD from your desktop or Start Menu. Sign in with your

Autodesk account to activate the license.

Launching AutoCAD for the First Time

When AutoCAD opens for the first time you will see the Start Tab. From here you can create a new

drawing, open a recent file, or access learning content.

1 Create a New Drawing

On the Start Tab, click New and select the template acad.dwt (the standard inches

template). Click Open.

2 Understand the Screen Layout

You will see: the Ribbon at the top, the Command Line at the bottom, the large white

Drawing Area in the center, and the Status Bar at the very bottom.

3 Save Your File Right Away

Press Ctrl+S, give the file a name like My_First_Drawing, and save it to a folder you can

find easily. Always save often!

■

NOTE

Always save your drawings frequently using Ctrl+S. AutoCAD does auto-save every

10 minutes by default, but manual saving protects your work.

↑ Back to Table of Contents
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CHAPTER 2

Navigating the AutoCAD Interface

Before drawing anything, you need to feel comfortable navigating the AutoCAD workspace. Understanding

the interface is the single most important skill for a beginner.

■
■ AutoCAD 2024 Interface Overview for Beginners

A 15-minute walkthrough of every part of the AutoCAD 2024 interface — ribbon, command
line, drawing area, and status bar explained clearly.

https://www.youtube.com/results?search_query=autocad+2024+interface+tour+beginners

Interface Areas at a Glance

Interface Area Location What It Does

Application Menu Top-left 'A' button Open, Save, Print, Export files

Quick Access Toolbar Top-left bar Undo, Redo, Save shortcuts

Ribbon Top of screen All commands organized into tabs & panels

Drawing Area Center (white/dark area) Where you create and view your drawing

Command Line Bottom bar Type commands; read AutoCAD prompts here

Status Bar Very bottom Toggle Snap, Grid, OSNAP, coordinates

Navigation Bar Right side Zoom, Pan, ViewCube controls

Crosshair Cursor Inside drawing area Your drawing pointer — follows the mouse

The Command Line — Your Best Friend

The Command Line is the most important part of AutoCAD. Every action you perform is shown here —

and most are faster to trigger by simply typing a command name or shortcut and pressing Enter or the

Spacebar.

1 Click inside the Command Line area

Click at the bottom of the screen where it shows the blinking cursor. You are now ready to

type a command.

AutoCAD 2024 — Basic Drafting Guide Page 6 of 30

https://www.youtube.com/results?search_query=autocad+2024+interface+tour+beginners
https://www.youtube.com/results?search_query=autocad+2024+interface+tour+beginners


2 Type a command and press Enter

For example, type LINE and press Enter. AutoCAD will prompt you to specify the first

point.

3 Respond to prompts

AutoCAD will guide you step-by-step. Read each prompt carefully and respond by clicking

in the drawing area or typing coordinates.

4 Press Escape to cancel

At any time, press the Esc key to cancel the current command and return to the ready

state.

5 Press Enter or Spacebar to repeat last command

Pressing Enter or Spacebar when no command is active repeats your last-used

command — a huge time saver!

Zooming & Panning

You will need to navigate around your drawing constantly. Here are the essential navigation controls:

Action How To Do It

Zoom In Scroll mouse wheel UP (forward)

Zoom Out Scroll mouse wheel DOWN (back)

Zoom Extents (fit all) Type Z then Enter, then E then Enter — or double-click scroll wheel

Pan (move the view) Hold the scroll wheel and drag the mouse

Zoom to a window Type Z then Enter, then W then Enter — click two corners

★

TIP

Double-clicking the scroll wheel zooms to extents — fitting your entire drawing on

screen. Use this constantly to re-orient yourself.

↑ Back to Table of Contents
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CHAPTER 3

Setting Up Your Drawing

Before drawing anything meaningful, you must configure your drawing environment. Correct units, grid,

and snapping settings are the foundation of accurate drawings.

■
■ Setting Up a New Drawing in AutoCAD 2024

Covers units, drawing limits, grid, snap, and Object Snap (OSNAP) setup from scratch.
Perfect first-setup walkthrough for beginners.

https://www.youtube.com/results?search_query=autocad+2024+drawing+setup+units+grid+osnap

Setting Units

AutoCAD can work in inches, feet, millimeters, or other units. Always set your units before you start

drawing.

1 Open the Units Dialog

Type UNITS in the Command Line and press Enter. The Drawing Units dialog box opens.

2 Set Length Type

Under Length, choose Decimal for metric/millimeters or Architectural for feet and

inches.

3 Set Precision

Choose your decimal precision — 0.00 is common for most work.

4 Set Insertion Scale

Set to Millimeters or Inches depending on your project.

5 Click OK

Click OK to apply. Your drawing is now set to correct units.

Grid & Snap Settings

The Grid shows a dot or line pattern in the drawing area for visual reference. Snap forces your cursor to

jump to exact intervals — essential for precise drawing.
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1 Open Drafting Settings

Right-click the SNAP or GRID button on the Status Bar at the bottom of the screen.

Select Snap Settings.

2 Set Snap Spacing

Under Snap X spacing type a value like 1 (for 1mm or 1 inch). Snap Y spacing will match

automatically.

3 Set Grid Spacing

Under Grid X spacing, type 5 (5mm or 5 inch). Grid lines are visual only — they do not

print.

4 Enable Snap and Grid

Check both Snap On and Grid On checkboxes, then click OK.

5 Toggle on/off

Press F7 to toggle Grid on/off. Press F9 to toggle Snap on/off. You can also click them on

the Status Bar.

Object Snap (OSNAP)

Object Snap (OSNAP) is one of AutoCAD's most powerful features. It lets your cursor automatically lock

onto exact points on existing objects — like endpoints, midpoints, and centers.

OSNAP Mode What It Snaps To Icon Symbol

Endpoint The exact start or end of a line, arc, or polyline Square

Midpoint The exact middle of a line or arc Triangle

Center The center point of a circle or arc Circle

Intersection Where two objects cross each other X mark

Perpendicular A point exactly 90° from a line Right angle

Nearest The closest point on any object Hourglass

1 Open OSNAP Settings

Right-click the OSNAP button on the Status Bar and choose Object Snap Settings.

2 Enable recommended modes

Check: Endpoint, Midpoint, Center, Intersection, Perpendicular. These cover 95% of

your drawing needs.
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3 Toggle OSNAP on/off

Press F3 or click the OSNAP button on the Status Bar. Keep it ON during most drawing

tasks.

★

TIP

When OSNAP is active, hover your cursor near a point — you will see a colored

marker and tooltip appear. That marker confirms AutoCAD will snap precisely to that

point when you click.

↑ Back to Table of Contents
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CHAPTER 4

Basic Drawing Commands

These are the fundamental drawing commands that form the building blocks of every AutoCAD drawing.

Master these five commands and you can create almost any 2D shape.

■
■ AutoCAD Basic Drawing Commands — LINE, CIRCLE, RECTANGLE & ARC

Step-by-step demonstration of the core drawing commands in AutoCAD 2024. Watch each
command in action before trying the exercises below.

https://www.youtube.com/results?search_query=autocad+2024+basic+draw+commands+line+circle+arc
+rectangle

The LINE Command

LINE Shortcut: L

Description: Draws straight line segments between two or more points.

Usage: Type L → click start point → click end point → press Enter to finish

1 Start the LINE command

Type L and press Enter, or click the Line tool in the Home > Draw panel on the Ribbon.

2 Specify the first point

Click anywhere in the drawing area for the starting point, or type exact coordinates like

0,0 and press Enter.

3 Specify the next point

Move your mouse and click, or type a distance and angle. Example: type @100,0 for a

horizontal line 100 units long.

4 Continue or finish

Keep clicking to add more connected segments, or press Enter or Esc to end the

command.

5 Close a shape

Type C and press Enter to automatically connect the last point back to the first point,

closing the shape.
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★

TIP

Coordinate input: @x,y means relative (from last point). @distance<angle means polar

(e.g. @50<45 = 50 units at 45 degrees). Direct distance: type a number while pointing

the mouse in a direction.

The CIRCLE Command

CIRCLE Shortcut: C

Description: Draws a perfect circle by center and radius (default), or by other methods.

Usage: Type C → click center → type/click radius

1 Start the CIRCLE command

Type C and press Enter.

2 Specify the center point

Click a point in the drawing area, or type coordinates like 50,50 and press Enter.

3 Specify the radius

Type a number (e.g. 25) and press Enter, or click a point to define the radius visually.

4 Alternative: Diameter

After starting CIRCLE, type D and press Enter, then type the diameter value instead of

radius.

5 Alternative: 3-Point Circle

After starting CIRCLE, type 3P, then click three points that the circle must pass through.

The RECTANGLE Command (RECTANG)

RECTANG Shortcut: REC

Description: Draws a closed rectangular polyline by specifying two opposite corners.

Usage: Type REC → click first corner → click or type opposite corner

1 Start RECTANG

Type REC and press Enter.

2 Specify first corner

Click in the drawing area, or type coordinates like 0,0.
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3 Specify opposite corner

Click the opposite corner diagonally, or type @200,100 to create a 200×100 rectangle

relative to the first corner.

4 Add chamfers or fillets (optional)

Before picking corners, type F for Fillet (rounded corners) or C for Chamfer (angled

corners) and set a value.

The ARC Command

ARC Shortcut: A

Description: Draws a curved arc. Default method: Start, Center, End.

Usage: Type A → click start → click center → click end

1 Start the ARC command

Type A and press Enter.

2 Specify the start point

Click the starting point of the arc.

3 Specify the center

Click the center point around which the arc curves.

4 Specify the end point

Click or type the endpoint. The arc draws counterclockwise from start to end by default.

5 Other arc methods

You can also use Start-End-Radius (type E then R at the prompts) or use the Ribbon's

Arc dropdown to choose other methods.

The POLYLINE Command

PLINE Shortcut: PL

Description: Draws connected line and arc segments as a single object. Better than LINE for

closed shapes.

Usage: Type PL → click points → press Enter to finish
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1 Start PLINE

Type PL and press Enter.

2 Click points

Click each vertex (corner) of your shape, just like the LINE command.

3 Switch to Arc mode

During PLINE, type A to switch to arc mode, then type L to switch back to line mode.

4 Close the polyline

Type C and press Enter to connect back to the start, forming a perfectly closed shape.

★

TIP

Use PLINE instead of LINE when you want a closed shape that behaves as one

object. This makes selecting, moving, and measuring much easier.

↑ Back to Table of Contents

AutoCAD 2024 — Basic Drafting Guide Page 14 of 30



CHAPTER 5

Modifying Objects

Drawing commands create objects; modify commands let you edit them. These six commands are the

most commonly used modify tools in everyday drafting.

■
■ AutoCAD Modify Commands — MOVE, COPY, MIRROR, TRIM, OFFSET

Clear visual demonstrations of all essential modify commands in AutoCAD 2024. Watch
this video alongside this chapter for best results.

https://www.youtube.com/results?search_query=autocad+2024+modify+commands+move+copy+trim+o
ffset

The ERASE Command

ERASE Shortcut: E

Description: Deletes selected objects from the drawing.

Usage: Type E → select objects → press Enter

1 Start ERASE

Type E and press Enter.

2 Select objects

Click each object you want to delete. Selected objects turn dashed.

3 Confirm

Press Enter to delete them.

4 Undo a mistake

Press Ctrl+Z immediately to undo the erase.

The MOVE Command

MOVE Shortcut: M
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Description: Moves selected objects from one location to another.

Usage: Type M → select → Enter → click base point → click destination

1 Start MOVE

Type M and press Enter.

2 Select objects

Click objects to move. Press Enter when done selecting.

3 Click a base point

Click a reference point on the object (use OSNAP for precision).

4 Click the destination

Click where you want to place the object, or type a relative distance like @50,0.

The COPY Command

COPY Shortcut: CO

Description: Copies selected objects to a new location. Original stays in place.

Usage: Type CO → select → Enter → base point → destination

1 Start COPY

Type CO and press Enter.

2 Select & base point

Select objects, press Enter, then click a base point.

3 Click destinations

Click multiple locations to place multiple copies.

4 Press Escape to finish

Press Esc when done copying.

The MIRROR Command

MIRROR Shortcut: MI

Description: Creates a mirror image of objects across a defined line.

Usage: Type MI → select → Enter → pick two points for mirror line
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1 Start MIRROR

Type MI and press Enter.

2 Select objects

Select objects to mirror. Press Enter.

3 Define the mirror line

Click two points to define the axis of reflection. A vertical mirror line keeps the X the same

on both sides.

4 Keep or delete original

AutoCAD asks: Delete source objects? Type N (keep both) or Y (delete original).

The TRIM Command

TRIM Shortcut: TR

Description: Trims objects at a cutting edge (another object's boundary).

Usage: Type TR → select cutting edges → Enter → click parts to trim

1 Start TRIM

Type TR and press Enter.

2 Select cutting edges

Click the object(s) that will act as the cutting boundary, then press Enter. Or press Enter

immediately to use all objects as cutting edges.

3 Click to trim

Click the part of each line or arc you want to remove (the part that crosses the cutting

edge).

4 Press Escape to finish

Press Esc when done.

The OFFSET Command

OFFSET Shortcut: O

Description: Creates a parallel copy of a line, circle, or polyline at a specified distance.

Usage: Type O → type distance → click object → click which side
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1 Start OFFSET

Type O and press Enter.

2 Type the offset distance

Type a number (e.g. 10) and press Enter.

3 Select the object

Click the line, circle, or arc to offset.

4 Choose the side

Click on the side of the object where you want the offset copy.

5 Continue or press Escape

Click more objects to keep offsetting, or press Esc to end.

★

TIP

To select multiple objects at once: click and drag LEFT-to-RIGHT to select only

objects completely inside the box (blue box). Drag RIGHT-to-LEFT to select

everything the box touches (green box).

↑ Back to Table of Contents
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CHAPTER 6

Layers & Properties

Layers are one of the most important organizational tools in AutoCAD. Think of them like transparent

sheets stacked on top of each other — each sheet holds different types of objects (walls, dimensions, text,

etc.) that you can show, hide, or lock independently.

■
■ AutoCAD Layers — Complete Beginner's Guide

Full explanation of layers in AutoCAD: creating, naming, color-coding, and using layers to
organize your drawing professionally.

https://www.youtube.com/results?search_query=autocad+2024+layers+tutorial+beginners+properties

What Are Layers?

Every object in AutoCAD lives on a layer. By default, all objects go on Layer 0. Good practice is to create

separate layers for: walls, doors, windows, dimensions, text, electrical, plumbing, etc. Each layer has its

own color, linetype, and lineweight.

Creating Layers

1 Open the Layer Properties Manager

Type LA and press Enter, or click the Layer Properties button in the Home > Layers

panel on the Ribbon.

2 Create a new layer

Click the New Layer button (it looks like a sheet with a star). A new layer named 'Layer1'

appears — type a descriptive name immediately, like WALLS or DIMENSIONS.

3 Set the layer color

Click the color swatch next to the layer name. Choose a color that helps you identify the

layer visually (e.g. Red for walls, Blue for dimensions).

4 Set linetype (optional)

Click the Continuous linetype to change it. For dashed lines, click Load and select a

linetype like DASHED or HIDDEN.
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5 Set lineweight (optional)

Click the lineweight value to change line thickness. 0.25mm is typical for most lines;

0.50mm for heavy/visible lines.

6 Close the Layer Manager

Click the X to close. Your layers are now ready to use.

Working with Layers

1 Set the current layer

In the Layer dropdown on the Ribbon (Home > Layers panel), click the name of the layer

you want to draw on. All new objects will go on that layer.

2 Move objects to a different layer

Select the object(s), then change the layer in the Layer dropdown. The objects

immediately move to the new layer.

3 Turn a layer off

In the Layer Properties Manager or Layer dropdown, click the light bulb icon. Objects on

that layer become invisible (but still exist).

4 Freeze a layer

Click the snowflake icon to freeze. Frozen layers are invisible AND not calculated by

AutoCAD — speeds up performance on large drawings.

5 Lock a layer

Click the lock icon to lock a layer. Objects on locked layers are visible but cannot be

selected or edited — great for reference layers.

■

NOTE

Never draw everything on Layer 0. Organize your drawing with named layers from

the start — it is very difficult to reorganize layers later on a complex drawing.

Recommended Starter Layer Setup

Layer Name Color Linetype Lineweight Purpose

0 White Continuous Default Default layer — avoid drawing here

WALLS White/7 Continuous 0.50mm Main building elements

DOORS Cyan/4 Continuous 0.25mm Door swings and openings

WINDOWS Green/3 Continuous 0.25mm Window openings

DIMENSIONS Blue/5 Continuous 0.18mm All dimension annotations

TEXT Red/1 Continuous 0.18mm Notes, labels, titles
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HIDDEN Yellow/2 HIDDEN 0.18mm Hidden/invisible edges

CENTERLINE Magenta/6 CENTER 0.18mm Centerlines of circles/arcs

HATCH Gray/8 Continuous 0.13mm Fill patterns and hatching

↑ Back to Table of Contents
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CHAPTER 7

Dimensions & Text Annotations

No technical drawing is complete without dimensions and text. AutoCAD 2024 has powerful annotation

tools that automatically measure and label your geometry.

■
■ Dimensions & Text in AutoCAD 2024 for Beginners

Learn how to add linear, angular, radius and diameter dimensions, plus MTEXT notes and
leaders in AutoCAD 2024. Includes Dimension Style setup.

https://www.youtube.com/results?search_query=autocad+2024+dimensions+text+mtext+beginner

Setting Up a Dimension Style

Before adding dimensions, create a Dimension Style so all your dimensions look consistent and are

scaled correctly for your drawing.

1 Open Dimension Style Manager

Type DIMSTYLE (or D) and press Enter. The Dimension Style Manager opens.

2 Create a new style

Click New, give it a name like MY_DIM_STYLE, and click Continue.

3 Set text height

On the Text tab, set Text Height to 2.5 (for mm drawings) or 0.125 (for inch drawings).

4 Set arrow size

On the Symbols and Arrows tab, set Arrow Size to match your text height (2.5).

5 Set overall scale

On the Fit tab, set Overall Scale to match your drawing scale (e.g. 1 for 1:1 drawings).

6 Set current style

Click Set Current on your new style, then click Close.

Linear Dimensions (DIMLINEAR)

DIMLINEAR Shortcut: DLI
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Description: Places a horizontal or vertical dimension measuring the distance between two

points.

Usage: Type DLI → click first point → click second point → click dimension placement

1 Type DLI and press Enter

Or go to Annotate > Dimensions > Linear on the Ribbon.

2 Snap to first point

With OSNAP active, click the first endpoint of what you are measuring.

3 Snap to second point

Click the second endpoint.

4 Place the dimension line

Move your mouse away from the object and click to set the dimension line location.

AutoCAD shows the measurement automatically.

Radius & Diameter Dimensions

DIMRADIUS /
DIMDIAMETER

Shortcut: DRA / DDI

Description: Dimensions the radius or diameter of a circle or arc.

Usage: Type DRA or DDI → click the circle/arc → place dimension

1 For radius: type DRA + Enter

Click the circle or arc edge. Move mouse to set dimension placement.

2 For diameter: type DDI + Enter

Click the circle edge. Move mouse to set dimension placement.

3 For angular dimensions: type DAN + Enter

Click the first line, then the second line. Move mouse to set the angle dimension.

Adding Text with MTEXT

MTEXT Shortcut: MT

Description: Places multi-line formatted text anywhere in the drawing.

Usage: Type MT → click two corners for text box → type text → click OK
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1 Type MT and press Enter

Or go to Annotate > Text > Multiline Text.

2 Define the text box

Click two opposite corners to define the area where the text will fit.

3 The text editor opens

A formatting toolbar appears. Type your text normally.

4 Format the text

Select text to change font, size, bold, italic using the toolbar.

5 Click Close Text Editor

Click outside the text box or click Close Text Editor in the Ribbon to finish.

★

TIP

Use DDEDIT (or double-click any dimension or text) to edit existing annotations

without deleting and redrawing them.

↑ Back to Table of Contents
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CHAPTER 8

Saving, Printing & Sharing

Once your drawing is complete, you need to save it correctly, set it up for printing, and export it in formats

others can use. This chapter covers the complete workflow from save to output.

■
■ How to Print & Plot in AutoCAD 2024 — Complete Beginner Guide

Covers Page Setup, choosing a plotter/printer, scale settings, and exporting to PDF. One
of the most important workflows for delivering finished drawings.

https://www.youtube.com/results?search_query=autocad+2024+print+plot+pdf+tutorial

Saving Your Work

1 Save (Ctrl+S)

Saves the file in its current format and location. Do this constantly.

2 Save As (Ctrl+Shift+S)

Opens a dialog to choose a new file name, location, or format.

3 Save as older format

In the Save As dialog, change Files of type to an older version like AutoCAD 2018

(.dwg) if sharing with users who have older AutoCAD.

4 AutoSave

AutoCAD auto-saves to a .sv$ file every 10 minutes. To change this, go to Application

Menu > Options > Open and Save and change the interval.

Using Drawing Templates (.DWT)

A template is a pre-configured drawing with your standard layers, dimension styles, text styles, and title

block already set up. Starting from a template saves setup time on every new drawing.

1 Set up a drawing exactly how you want it

Configure layers, styles, units, and add your title block.

2 Save as Template

Go to Application Menu > Save As > Drawing Template. Give it a name like

My_Company_Template.dwt.
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3 Use your template

When creating a new drawing, click New and browse to your .dwt file.

Page Setup & Plotting (Printing)

1 Switch to a Layout tab

At the bottom of the screen, click Layout1. This is your paper space for printing.

2 Open Page Setup Manager

Right-click the Layout tab and choose Page Setup Manager. Click Modify.

3 Choose your printer/plotter

In the Printer/Plotter dropdown, select your printer or choose DWG To PDF.pc3 to

export to PDF.

4 Set paper size

Choose your paper size (e.g. ANSI B 11x17 or ISO A1) from the Paper Size dropdown.

5 Set plot scale

In the Plot Scale section, choose Fit to paper for a quick print, or enter a specific scale

like 1:50 for a scaled drawing.

6 Set plot style

Choose monochrome.ctb to print all lines in black regardless of layer color.

7 Click OK then Plot

Click OK to save page setup, then press Ctrl+P to open the Plot dialog and click OK to

print.

Exporting to PDF

1 Method 1 — Plot to PDF

Press Ctrl+P, select DWG To PDF.pc3 as the plotter. A PDF will be created instead of

printing on paper.

2 Method 2 — Export to PDF

Go to Application Menu > Export > PDF. More options are available including

multi-sheet PDFs.

3 Set PDF quality

In the Export to PDF dialog, set Quality to High for presentations, Medium for everyday

sharing.
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4 Choose output location

Browse to your desired folder and click Save. The PDF is ready to share immediately.

■

NOTE

Always review your drawing in the Layout/Paper Space view before plotting. Model

Space is for drawing; Paper Space is for presenting and printing with correct scale

and title block.

↑ Back to Table of Contents
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CHAPTER R

References & Web Resources

The following curated resources are the best on the web for learning AutoCAD 2024. Each section

includes direct links. Click any link to open it in your browser.

■ Official Autodesk Resources

Official Autodesk AutoCAD 2024 Official Documentation

The complete official reference manual for AutoCAD 2024. Search any command,
option, or concept.

Official Autodesk AutoCAD Learning Path

Autodesk's official structured learning paths from beginner to certified professional.

Official AutoCAD Free Trial Download

Download the official 30-day free trial of AutoCAD 2024. No credit card required.

Official Autodesk Knowledge Network

Troubleshooting articles, how-to guides, FAQs, and community answers from
Autodesk.

■ Best Video Tutorial Channels

■
■ CAD in Black — AutoCAD 2024 for Beginners (Complete Playlist)

One of the top AutoCAD tutorial channels on YouTube. Clear, beginner-friendly tutorials
covering every topic in this guide and beyond. Highly recommended as your primary video
source.

https://www.youtube.com/@CADinBlack

■
■ JOKO ENGINEERING — AutoCAD 2024 Tutorials

Practical AutoCAD tutorials with real engineering and architecture examples. Excellent for
seeing commands applied in professional contexts.

https://www.youtube.com/@JokoEngineering
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■
■ AutoCAD Tutorials by Balkan Architect

Architecture-focused AutoCAD tutorials. Great for students learning to draw floor plans,
sections, and elevations from scratch.

https://www.youtube.com/@BalkanArchitect

■
■ Autodesk Official YouTube Channel

Official tutorials, feature spotlights, and what's new videos directly from Autodesk. Reliable,
accurate content for every version.

https://www.youtube.com/@Autodesk

■
■ The CAD Academy — AutoCAD for Beginners

Structured beginner course covering the full workflow from opening AutoCAD to printing a
finished drawing. Covers many topics in this guide with on-screen demonstrations.

https://www.youtube.com/@TheCADAcademy

■ Free Online Courses & Tutorials

Tutorial Autodesk Instructables — Free AutoCAD Class

A free structured class covering the full AutoCAD basics. Includes written lessons and
exercises you can follow step-by-step.

Tutorial LinkedIn Learning — AutoCAD 2024 Essential Training

Professional video course by Scott Onstott. Covers beginner through intermediate
topics. Free with LinkedIn Premium or public library card.

Tutorial GrabCAD Community — AutoCAD Tutorials

Community-contributed tutorials and project examples. Good for seeing real-world
AutoCAD drawings and following practical exercises.

Tutorial Udemy — AutoCAD 2024 Courses (Search Free & Paid)

Hundreds of AutoCAD courses. Many go on sale for under $15. Look for highly-rated
courses with 4.5+ stars and 1000+ reviews.

■ Community Forums & Help

Forum Autodesk Community Forums — AutoCAD

The official AutoCAD user forum. Ask questions and get answers from experienced
AutoCAD users and Autodesk staff worldwide.
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Forum Reddit — r/AutoCAD

Active community of AutoCAD users. Post questions, share drawings, and find tips
and tricks from users of all skill levels.

Forum CADTutor — AutoCAD Tutorials & Forum

Long-running CAD tutorial website with free written tutorials and an active user forum
for getting help with specific problems.

■ AutoCAD 2024 Essential Keyboard Shortcuts

Command Shortcut Command Shortcut

LINE L ERASE E

CIRCLE C MOVE M

RECTANG REC COPY CO

ARC A MIRROR MI

PLINE PL TRIM TR

OFFSET O EXTEND EX

LAYERS LA ZOOM Extents Z → E

MTEXT MT PAN P

DIMLINEAR DLI PROPERTIES PR

DIMRADIUS DRA UNDO Ctrl+Z

HATCH H REDO Ctrl+Y

SAVE Ctrl+S SELECT ALL Ctrl+A

PLOT/PRINT Ctrl+P OSNAP toggle F3

UNITS UNITS GRID toggle F7

SNAP toggle F9 ORTHO toggle F8

Ready for the Next Step?

Once you have mastered the content in this guide, continue to the AutoCAD 2024 Intermediate

Drafting Guide, which covers: Blocks & Attributes, External References (Xrefs), Viewports & Paper

Space, Advanced Dimensions, Hatch Patterns, Drawing Standards, and more.
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